The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

Hortonworks Sandbox Forum

Update tutorials failed

  • #33089

    I download the sandbox on my mac mini, and it works good so far.
    But, the tutorials component (version: 1.0.005) can’t be updated!
    What can I do to fix it?

    Update tutorials failed: RAN: ‘/bin/bash /usr/lib/tutorials/tutorials_app/run/’ STDOUT: Pull… STDERR: ssh: Could not resolve hostname Name or service not known fatal: The remote end hung up unexpectedly

  • Author
  • #33407
    Cheryle Custer

    The 1.0.005 version is the most current version of the tutorials. If you don’t see any tutorial in the left hand pane, disconnect from the internet and boot the Sandbox. It comes configured with tutorials but upon boot will connect to GitHub to pull the most current. If there is an outage on GitHub, you may find the errors you describe.

    Bijoy Deb

    I am also getting the same error.I tried rebooting the sandbox,but still the same error after reboot.Please let know the fix.

    Cheryle Custer

    if you are experiencing an error that says GitHub is unavailable AND it prevents you from using the Sandbox, please disconnect from the Internet and boot the Sandbox.

    Bijoy Deb

    I tried disconnecting from internet,and rebooting sandbox on VMWarePlayer,but still getting the same error.
    Why is it asking to check for latest update,instead of showing at least an older version.
    Is there any other workaround to this?This issue is coming only for the first 2 tutorial links–>YARN and TEZ tutorials.
    Please suggest.


    I had this same error as OP and it was a problem with the network connection, not necessarily a physical connection on my end, but maybe a firewall rule? In any case, moving to a new location (in this case, 4g tethering) and trying the update again let it go through fine.

    Currently my Tutorials version is on 1.0.006, there should have been a new release sometime yesterday I believe [reference]. However, I don’t see the tutorial 12 referenced in that article, even tried rebooting the VM.

    Cheryle Custer


    Which version of the Sandbox are you using? If you are on the 2.0 Community Preview there are no new tutorials.


    Bijoy Deb

    Hi Cheryle,
    I am indeed using the HDP 2.0 Community Preview version.But the thing is I am not able to open the existing 1.0.005 tutorial as well,getting the ‘Update Tutorial failed’ error even when I am just clicking on YARN or TEZ tutorial link.

    Bijoy Deb

    One minor correction to my earlier reply.Clicking on YARN/TEZ tutorial links gives the below message,asking me to perform an update:
    “Please update the tutorials to get our latest tutorial on YARN. Click the HUE icon in the upper left corner of the HUE toolbar, then click “Update” next to the Tutorials section of the Component/Version table.”

    And on trying to Update,I get the connection error I had mentioned earlier.

    Cheryle Custer

    Hi Bijoy,

    Hmmmm. Yes, you should be able to update the HDP 2.0 Community Preview to see the YARN and Tez tutorials. Have you tried the update while on a different network? I’m wondering if there is a firewall issue that’s blocking the update from GitHub?


    Will Fleming

    For me I noticed that the /etc/resolv.conf file on the sandbox VM instance only had a nameserver entry. I commented that out, then added a nameserver X.X.X.X with the X’s replaced with the nameserver configured on my host machine (reviewing the network card details). Additionally, I reconfigured the VM network card to be bridged. This allowed the sandbox to resolve

    Bijoy Deb

    I am trying this out on my office network,so there is not really much that I can try out with respect to network or firewall settings change.

    Could you clarify on what exactly did you put instead of in resolv.conf? Was it the host computer name Or host IP address?In other words,how do I find out the ‘nameserver configured on my host machine’?My host machine is Windows and I am running the sandbox via VMWare.


    Hi Bijoy,
    It would probably be best to start a new post. On your host machine, try to ping Are you able to ping? If you are able to ping, then you can check your dns servers by executing a ipconfig /all within the windows command prompt. It should provide the DNS servers your machine uses. Then you can log into the sandbox and verify if your dns matches with what’s on your host machine, nslookup command should display this. If I recall correctly, the bridged network interface setup should pick up the same dns servers as your host machine. By default that interface should be dhcp.

    Hope that helps.


The forum ‘Hortonworks Sandbox’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.