The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

Hortonworks Sandbox Forum

vt-x error while use Vbox

  • #14443
    Cheryle Custer
    Moderator

    User reports on Twitter they receive error: anyone get the vt-x error while trying to run #hortonworkssandbox @hortonworks using VirtualBox?

    Note from Hortonworks: Jack, please provide more details here. What version of Vbox, which OS and version, which browser.

    Thanks, Cheryle

  • Author
    Replies
  • #14449

    I got it to work on a different computer. I am running windows 7(64-bit) on both and used virtualbox 4.2.6. I am not sure what causes it malfunction on the first computer i tried it on, but it might be the RAM(first = 4gb, second = 6gb).
    Thanks,
    Jack

    #14450
    Cheryle Custer
    Moderator

    Thanks Jack. Were you running any other virtualization layer on the computer when you got the vt-x error? If you can reproduce the error can you please provide the full text of the error message? Looking at the Virtualbox forums, looks like there are several vt-x error conditions.

    Thanks

    #14454

    The following is the full text:
    Result Code:
    E_FAIL (0x80004005)
    Component:
    Console
    Interface:
    IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

    btw i reinstalled virtualbox and allocated more ram; still got the same error.

    #14455
    Cheryle Custer
    Moderator

    HI Jack,

    is your hardware enabled for virtualization? Are you running other virtualization layers?

    The VBox docs says this about the error https://forums.virtualbox.org/viewtopic.php?t=8669:
    You need a 64-bit processor with hardware virtualization support (see User Manual chapter 1.2, Software vs. hardware virtualization (VT-x and AMD-V), page 10) and a 64-bit host operating system.
    NOTE: Since version 2.1.0, you can run 64 bit Guests while running a 32 bit Host. The prior requirement for Operating System is only for version 2.0.x. You still need the proper hardware.

    #14460

    Hi Cheryle,

    It seems like i first need to upgrade my bios because the current one i have does not support virtualization. Other people with my same laptop had the same problem http://forums.lenovo.com/t5/IdeaPad-Y-U-V-Z-and-P-series/Y650-virtualization-Intel-VT-SOLVED/td-p/180339 .

    Thank you! I will keep you updated once i upgrade my bios.

The forum ‘Hortonworks Sandbox’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.