Hortonworks Sandbox Forum

WebHdfsException at /filebrowser/

  • #15723
    Aaron Bruce

    Hi, I’ve just installed the sandbox and when I attempt to open the file browser I get a WebHdfsException. Here’s the Exception info:

    WebHdfsException at /filebrowser/

    Request Method: GET
    Request URL:
    Django Version: 1.2.3
    Exception Type: WebHdfsException
    Exception Value:

    Exception Location: /home/sandbox/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py in _stats, line 182
    Python Executable: /home/sandbox/hue/build/env/bin/python2.7
    Python Version: 2.7.3

    Here’s the traceback:


    Request Method: GET
    Request URL:
    Django Version: 1.2.3
    Python Version: 2.7.3
    Installed Applications:
    Installed Middleware:

    File “/home/sandbox/hue/build/env/lib/python2.7/site-packages/Django-1.2.3-py2.7.egg/django/core/handlers/base.py” in get_response
    100. response = callback(request, *callback_args, **callback_kwargs)
    File “/home/sandbox/hue/apps/filebrowser/src/filebrowser/views.py” in index
    86. if not request.fs.isdir(path):
    File “/home/sandbox/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py” in isdir
    197. sb = self._stats(path)
    File “/home/sandbox/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py” in _stats
    182. raise ex

    Exception Type: WebHdfsException at /filebrowser/
    Exception Value:

to create new topics or reply. | New User Registration

  • Author
  • #15759

    Hi, I get the same error message. I think is due to a permission misconfiguration:

    hadoop.hdfs_clusters.default.webhdfs_url Current value: http://localhost:50070/webhdfs/v1/
    Failed to access filesystem root

    I’m still checking logs to find out which could be solution.
    In the meanwhile, is there anyone else who solved this error?

    Arnaud LINZ

    Same for me. No solution ?

    Larry Liu

    Hi, Aaron,

    I didn’t see the issue. Can you tell me the steps you see the issue? And are you using the new version of sandbox?


    Brad Lynch

    I am also receiving this error.

    I downloaded this the night of March 21, the filename is: Sandbox+HDP+Bombardier2+(14.03)+VMware.ova.

    Would like to be able to upload the first tutorial file. Thank you in advance if anybody knows how to fix this.


    Brad Lynch

    So mine is working now and the only thing I did since I posted is reboot the VM 2 times.

    Wish I could help more with the root cause, but now I am able to upload through the file manager and the configuration checker is now succeeding.

    Peter Rudenko

    Could you run on VM next command:
    curl -i "http://sandbox:50070/webhdfs/v1/?op=LISTSTATUS"

You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.