The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

Hortonworks Sandbox Forum

What is the right network config for a 1.3 Sandbox running within VMware Player?

  • #38054

    The VMware player instructions still recommend having two network adapters: 1 NAT and 1 Host-Only. When I created a new 1.3 VM just now I had to add the Host-Only adapter. The VM starts up ok and I can get to the main web page.

    But to update the tutorials, I need to be able to access from the VM. But I can’t do that — I get is an unknown host.

    There is a rather draconian firewall on the Windows 7 Host that I can’t turn off. If I try to ping from the host in a command window, it fails there too.

    I have spent a lot of time with the 1.2 Sandbox and things kind of just worked there — no problems like this.

    I know VirtualBox is supposed to only need a single network interface, but I am not sure what to use for VMware player.

    I really want to try the 3 new tutorials!!


  • Author
  • #38065

    I went home and on my local network there, ping worked from the host (Windows 7) command shell. But ping inside the VM still did not work. So I shut down the VM, removed the Host-Only network adapter, restarted the VM and then ping worked inside the VM, AND I was able to update the tutorials.

    So it looks like even with VMware player, you don’t need 2 network adapters in the VM config.

    The installation docs on the Sandbox home page should be updated to reflect this.

    Will see if things work when I get back in the office tomorrow.


    Back in the office and the tutorial update attempt did not fail (github unknown host) with only the single NAT adapter configured for the 1.3 Sandbox VM. There were no new tutorials of course since I updated them yesterday.

    Ping outbound packets are blocked in the office network but ping not working was not directly indicative of any update problem.

    Looks like the cure for me was the right VMware network configuration: only one NAT’d interface.

The forum ‘Hortonworks Sandbox’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.