Home Forums HDP on Linux – Installation yum install ambari-server failing due to python26 conflict

This topic contains 3 replies, has 3 voices, and was last updated by  tedr 10 months, 4 weeks ago.

  • Creator
    Topic
  • #26214

    Roger Sibert
    Member

    I originally had the install work on SL 6 but since its not supported I swapped to CentOS 6 but when you go to install the ambari-server there’s a conflict that prevents it from working.

    [root@xyusfl333 ~]# yum install ambari-server
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: mirror.es.its.nyu.edu
    * epel: mirrors.ptd.net
    * extras: centos.mirror.lstn.net
    * updates: mirrors.cat.pdx.edu
    Setting up Install Process
    Resolving Dependencies
    –> Running transaction check
    —> Package ambari-server.noarch 0:1.2.3.6-1 will be installed
    –> Processing Dependency: python26 for package: ambari-server-1.2.3.6-1.noarch
    –> Running transaction check
    —> Package python26.x86_64 0:2.6.8-2.el5 will be installed
    –> Finished Dependency Resolution

    Dependencies Resolved

    =========================================================================================
    Package Arch Version Repository Size
    =========================================================================================
    Installing:
    ambari-server noarch 1.2.3.6-1 Updates-ambari-1.x 33 M
    Installing for dependencies:
    python26 x86_64 2.6.8-2.el5 epel 6.5 M

    Transaction Summary
    =========================================================================================
    Install 2 Package(s)

    Total size: 40 M
    Installed size: 70 M
    Is this ok [y/N]:

    After hitting Y you get a large # of python conflict messages along the line of below.
    file /usr/lib64/python2.6/traceback.pyo from install of python26-2.6.8-2.el5.x86_64 conflicts with file from package python-2.6.6-36.el6.x86_64
    file /usr/lib64/python2.6/tty.py from install of python26-2.6.8-2.el5.x86_64 conflicts with file from package python-2.6.6-36.el6.x86_64

    System is a fresh install of CentOS 6.4 (iso used is/was listed as minimal)

    Currently installed:
    [root@xyusfl333 ~]# python -V
    Python 2.6.6

    [root@xyusfl333 ~]# uname -a
    Linux xyusfl333 2.6.32-358.6.2.el6.x86_64 #1 SMP Thu May 16 20:59:36 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

    Does the install really need 2.6.8 or is there a way to upgrade the python to to the python26 package?

    Thanks,
    Roger

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #26423

    tedr
    Member

    Hi Roger,

    Good to hear that you got it to work by making sure that it was using the correct repositories.

    Thanks,
    Ted.

    Collapse
    #26229

    Roger Sibert
    Member

    I spent some time purging the repo and finally did get it to remove any reference to non-default repos.

    Re-installing and making sure the 6 instructions where followed cleaned up the mess.

    Key thing to remember is never talk hadoop with lustre while you are trying to configure servers.

    Many Thanks,
    Roger

    Collapse
    #26217

    Yi Zhang
    Moderator

    Hi Roger,

    Are you using the correct repo for cents 6? This looks like you are using the repo for centos5.

    Thanks,
    Yi

    Collapse
Viewing 3 replies - 1 through 3 (of 3 total)