Home Forums Hive / HCatalog Zookeeper connection refused

This topic contains 1 reply, has 2 voices, and was last updated by  Yi Zhang 11 months, 1 week ago.

  • Creator
    Topic
  • #39962

    Lebing XIE
    Member

    Hello,

    I installed HDP 1.3 cluster using Ambari. As I create hbase table in HIVE shell, log shows following error:

    2013-10-03 12:00:39,644 WARN zookeeper.ClientCnxn (ClientCnxn.java:run(1089)) – Session 0×0 for server null, unexpected error, closing socket connection and attempting reconnect
    java.net.ConnectException: Connection refused
    at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
    at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)
    at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350)
    at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1068)
    2013-10-03 12:00:39,760 WARN zookeeper.RecoverableZooKeeper (RecoverableZooKeeper.java:retryOrThrow(219)) – Possibly transient ZooKeeper exception: org.apache.zookeeper.KeeperException$ConnectionLossException: KeeperErrorCode = ConnectionLoss for /hbase-unsecure/hbaseid
    2013-10-03 12:00:40,759 WARN zookeeper.ClientCnxn (ClientCnxn.java:run(1089)) – Session 0×0 for server null, unexpected error, closing socket connection and attempting reconnect
    java.net.ConnectException: Connection refused
    at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
    at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)
    at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350)
    at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1068)
    2013-10-03 12:00:41,862 WARN zookeeper.ClientCnxn (ClientCnxn.java:run(1089)) – Session 0×0 for server null, unexpected error, closing socket connection and attempting reconnect
    java.net.ConnectException: Connection refused
    at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
    at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:567)
    at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350)
    at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1068)

    I did specify the parent node as “hbase-unsecure” in hive-core.xml. what is the reason?

    1. the version of hbase/ZK in HIVE lib are not the same in cluster?
    2. Hive attempted to connect ZK on localhost? how can I specify ZK host?

    Thanks!

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #39969

    Yi Zhang
    Moderator

    Hi Lebing,

    Try add property hbase.zookeeper.quorum.

    Thanks,
    Yi

    Collapse
Viewing 1 replies (of 1 total)